Discussion:
error: el registro está eliminado
(demasiado antiguo para responder)
jbmixed
2005-02-21 18:56:47 UTC
Permalink
Buenas tardes...

Intento sacar una consulta sobre una tabla y siempre me da ese error...

El caso es que mostrando todo el contenido de la tabla he encontrado un par
de filas
donde ponía #eliminado (o algo así) en todos los campos y he podido
borrarlas, pero sigue
dando el mismo error.

Existe alguna forma de localizar y eliminar estas filas?


Gracias y saludos,

Xus.
Pedro M Glez
2005-02-21 19:29:38 UTC
Permalink
Hola,

Prueba a reparar y compactar la base de datos a ver... Eso me parece que
era porque has borrado los registros y queda ahi el hueco hasta que se
compacta. Algo me sonaba de eso :???
Saludos,
Pedro Muñoz
La Coruña
Post by jbmixed
Buenas tardes...
Intento sacar una consulta sobre una tabla y siempre me da ese error...
El caso es que mostrando todo el contenido de la tabla he encontrado un par
de filas
donde ponía #eliminado (o algo así) en todos los campos y he podido
borrarlas, pero sigue
dando el mismo error.
Existe alguna forma de localizar y eliminar estas filas?
Gracias y saludos,
Xus.
--
Pedro Muñoz
La Coruña
Ju@nK
2005-02-21 19:50:47 UTC
Permalink
Es posible que tengas tablas relacionadas y que borrases registros de la
principal y no de la relacionada con lo que al hacer una consulta sobre esta
última te da el error. para eso es bueno al configurar las relaciones
marcar el borrar en cascada.
--
****************************************
Colabora con el grupo, contesta a este mensaje
y dinos si te sirvió o no la respuesta dada.
Muchas gracias.

Salu2
***@nK
www.juank.tk
www.mvp-access.com/***@nk
****************************************
Post by Pedro M Glez
Hola,
Prueba a reparar y compactar la base de datos a ver... Eso me parece que
era porque has borrado los registros y queda ahi el hueco hasta que se
compacta. Algo me sonaba de eso :???
Saludos,
Pedro Muñoz
La Coruña
Post by jbmixed
Buenas tardes...
Intento sacar una consulta sobre una tabla y siempre me da ese error...
El caso es que mostrando todo el contenido de la tabla he encontrado un
par de filas
donde ponía #eliminado (o algo así) en todos los campos y he podido
borrarlas, pero sigue
dando el mismo error.
Existe alguna forma de localizar y eliminar estas filas?
Gracias y saludos,
Xus.
--
Pedro Muñoz
La Coruña
jbmixed
2005-02-22 08:20:43 UTC
Permalink
Gracias, ha funcionando simplemente compactando y reparando... misterios de
access...

Saludos,

Xus.
Post by Pedro M Glez
Hola,
Prueba a reparar y compactar la base de datos a ver... Eso me parece que
era porque has borrado los registros y queda ahi el hueco hasta que se
compacta. Algo me sonaba de eso :???
Saludos,
Pedro Muñoz
La Coruña
Post by jbmixed
Buenas tardes...
Intento sacar una consulta sobre una tabla y siempre me da ese error...
El caso es que mostrando todo el contenido de la tabla he encontrado un
par de filas
donde ponía #eliminado (o algo así) en todos los campos y he podido
borrarlas, pero sigue
dando el mismo error.
Existe alguna forma de localizar y eliminar estas filas?
Gracias y saludos,
Xus.
--
Pedro Muñoz
La Coruña
CarCar
2005-02-22 09:33:16 UTC
Permalink
Hola:

Ese error se producía en tablas con más de un campo "memo" o si el
único campo "memo" de la tabla no era el último de los campos de la
misma. Comprueba si es así e intenta corregir el diseño de la tabla
implicada para que no te vuelva a ocurrir.

Saludos,
CarCar
Pedro M Glez
2005-02-22 11:23:58 UTC
Permalink
Me alegro. :)
Post by jbmixed
Gracias, ha funcionando simplemente compactando y reparando... misterios de
access...
Saludos,
Xus.
Post by Pedro M Glez
Hola,
Prueba a reparar y compactar la base de datos a ver... Eso me parece que
era porque has borrado los registros y queda ahi el hueco hasta que se
compacta. Algo me sonaba de eso :???
Saludos,
Pedro Muñoz
La Coruña
Post by jbmixed
Buenas tardes...
Intento sacar una consulta sobre una tabla y siempre me da ese error...
El caso es que mostrando todo el contenido de la tabla he encontrado un
par de filas
donde ponía #eliminado (o algo así) en todos los campos y he podido
borrarlas, pero sigue
dando el mismo error.
Existe alguna forma de localizar y eliminar estas filas?
Gracias y saludos,
Xus.
--
Pedro Muñoz
La Coruña
--
Pedro Muñoz
La Coruña
Loading...